using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-z0-9\s]{1,11})(\s)(.*)";
string substitution = @"$1";
string input = @"The quick brown fox jumped over the fence, K: 11";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}