import Foundation
let pattern = #"([A-z0-9\s]{1,11})(\s)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"The quick brown fox jumped over the fence, K: 11"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}