// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-z0-9\s]{1,11})(\s)(.*)").unwrap();
let string = "The quick brown fox jumped over the fence, K: 11";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}