#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[+-]?\d+([.]\d+)?([+\-*/][+-]?\d+([.]\d+)?)*$"
Local $sString = "5+4" & @CRLF & _
"3+6*6-9/8" & @CRLF & _
"3.0+6.0" & @CRLF & _
"-1+-1" & @CRLF & _
"44-5" & @CRLF & _
"-7" & @CRLF & _
"+6" & @CRLF & _
"/8" & @CRLF & _
"*8" & @CRLF & _
"8.0" & @CRLF & _
"5.2.2" & @CRLF & _
"3.2+4" & @CRLF & _
"3.2+3.2" & @CRLF & _
"2+5.4" & @CRLF & _
"5--5" & @CRLF & _
"+5*4*3)" & @CRLF & _
"6*(4)" & @CRLF & _
"5*(5+6)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")