const regex = /^[+-]?\d+([.]\d+)?([+\-*/][+-]?\d+([.]\d+)?)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[+-]?\\d+([.]\\d+)?([+\\-*\/][+-]?\\d+([.]\\d+)?)*$', 'gm')
const str = `5+4
3+6*6-9/8
3.0+6.0
-1+-1
44-5
-7
+6
/8
*8
8.0
5.2.2
3.2+4
3.2+3.2
2+5.4
5--5
+5*4*3)
6*(4)
5*(5+6)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}