import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[+-]?\\d+([.]\\d+)?([+\\-*/][+-]?\\d+([.]\\d+)?)*$";
final String string = "5+4\n"
+ "3+6*6-9/8\n"
+ "3.0+6.0\n"
+ "-1+-1\n"
+ "44-5\n"
+ "-7\n"
+ "+6\n"
+ "/8\n"
+ "*8\n"
+ "8.0\n"
+ "5.2.2\n"
+ "3.2+4\n"
+ "3.2+3.2\n"
+ "2+5.4\n"
+ "5--5\n"
+ "+5*4*3)\n"
+ "6*(4)\n"
+ "5*(5+6)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}