package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?\d+([.]\d+)?([+\-*/][+-]?\d+([.]\d+)?)*$`)
var str = `5+4
3+6*6-9/8
3.0+6.0
-1+-1
44-5
-7
+6
/8
*8
8.0
5.2.2
3.2+4
3.2+3.2
2+5.4
5--5
+5*4*3)
6*(4)
5*(5+6)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}