using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[+-]?\d+([.]\d+)?([+\-*/][+-]?\d+([.]\d+)?)*$";
string input = @"5+4
3+6*6-9/8
3.0+6.0
-1+-1
44-5
-7
+6
/8
*8
8.0
5.2.2
3.2+4
3.2+3.2
2+5.4
5--5
+5*4*3)
6*(4)
5*(5+6)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}