import Foundation
let pattern = #"^[+-]?\d+([.]\d+)?([+\-*/][+-]?\d+([.]\d+)?)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
5+4
3+6*6-9/8
3.0+6.0
-1+-1
44-5
-7
+6
/8
*8
8.0
5.2.2
3.2+4
3.2+3.2
2+5.4
5--5
+5*4*3)
6*(4)
5*(5+6)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)