// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[+-]?\d+([.]\d+)?([+\-*/][+-]?\d+([.]\d+)?)*$").unwrap();
let string = "5+4
3+6*6-9/8
3.0+6.0
-1+-1
44-5
-7
+6
/8
*8
8.0
5.2.2
3.2+4
3.2+3.2
2+5.4
5--5
+5*4*3)
6*(4)
5*(5+6)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}