# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(#+.*?)With Space/$1WithSpace/gm;t' <<< "#ThisIsaHashtagWith Space test #ThisIsaHashtagWith Space"