// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(#+.*?)With Space").unwrap();
let string = "#ThisIsaHashtagWith Space test #ThisIsaHashtagWith Space";
let substitution = "$1WithSpace";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}