package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(#+.*?)With Space`)
var str = `#ThisIsaHashtagWith Space test #ThisIsaHashtagWith Space`
var substitution = "$1WithSpace"
fmt.Println(re.ReplaceAllString(str, substitution))
}