const regex = /(#+.*?)With Space/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(#+.*?)With Space', 'gm')
const str = `#ThisIsaHashtagWith Space test #ThisIsaHashtagWith Space`;
const subst = `$1WithSpace`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);