use strict;
my $str = '#ThisIsaHashtagWith Space test #ThisIsaHashtagWith Space';
my $regex = qr/(#+.*?)With Space/mp;
my $subst = '$1WithSpace';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";