import Foundation
let pattern = ##"(#+.*?)With Space"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"#ThisIsaHashtagWith Space test #ThisIsaHashtagWith Space"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1WithSpace"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)