re = /(#+.*?)With Space/m
str = '#ThisIsaHashtagWith Space test #ThisIsaHashtagWith Space'
subst = '$1WithSpace'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result