#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^# /// (?P<type>[a-zA-Z0-9-]+)$\s(?P<content>(^#(| .*)$\s)+?)^# ///$" & @CRLF & _
""
Local $sString = "# /// pyproject" & @CRLF & _
"# [run]" & @CRLF & _
"# dependencies = ["requests<3"]" & @CRLF & _
"# ///" & @CRLF & _
"#" & @CRLF & _
"# This data is no longer being read" & @CRLF & _
"# if someone has accidentally bridged" & @CRLF & _
"# two metadata blocks without a blank" & @CRLF & _
"# line." & @CRLF & _
"#" & @CRLF & _
"# /// pyproject" & @CRLF & _
"# With the mode set to lazy instead " & @CRLF & _
"# this can be parsed as a second" & @CRLF & _
"# pyproject block and give the expected" & @CRLF & _
"# error for there being two blocks" & @CRLF & _
"# of the same type." & @CRLF & _
"# ///" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")