# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?m)^# /// (?P<type>[a-zA-Z0-9-]+)$\s(?P<content>(^#(| .*)$\s)+?)^# ///$\n")
test_str = ("# /// pyproject\n"
"# [run]\n"
"# dependencies = [\"requests<3\"]\n"
"# ///\n"
"#\n"
"# This data is no longer being read\n"
"# if someone has accidentally bridged\n"
"# two metadata blocks without a blank\n"
"# line.\n"
"#\n"
"# /// pyproject\n"
"# With the mode set to lazy instead \n"
"# this can be parsed as a second\n"
"# pyproject block and give the expected\n"
"# error for there being two blocks\n"
"# of the same type.\n"
"# ///\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.