package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)^# /// (?P<type>[a-zA-Z0-9-]+)$\s(?P<content>(^#(| .*)$\s)+?)^# ///$
`)
var str = `# /// pyproject
# [run]
# dependencies = ["requests<3"]
# ///
#
# This data is no longer being read
# if someone has accidentally bridged
# two metadata blocks without a blank
# line.
#
# /// pyproject
# With the mode set to lazy instead
# this can be parsed as a second
# pyproject block and give the expected
# error for there being two blocks
# of the same type.
# ///
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}