import Foundation
let pattern = ##"""
(?m)^# /// (?P<type>[a-zA-Z0-9-]+)$\s(?P<content>(^#(| .*)$\s)+?)^# ///$
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# /// pyproject
# [run]
# dependencies = ["requests<3"]
# ///
#
# This data is no longer being read
# if someone has accidentally bridged
# two metadata blocks without a blank
# line.
#
# /// pyproject
# With the mode set to lazy instead
# this can be parsed as a second
# pyproject block and give the expected
# error for there being two blocks
# of the same type.
# ///
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)