use strict;
my $str = '# /// pyproject
# [run]
# dependencies = ["requests<3"]
# ///
#
# This data is no longer being read
# if someone has accidentally bridged
# two metadata blocks without a blank
# line.
#
# /// pyproject
# With the mode set to lazy instead
# this can be parsed as a second
# pyproject block and give the expected
# error for there being two blocks
# of the same type.
# ///
';
my $regex = qr/(?m)^# /// (?P<type>[a-zA-Z0-9-]+)$\s(?P<content>(^#(| .*)$\s)+?)^# ///$
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}