re = /(?m)^# \/\/\/ (?P<type>[a-zA-Z0-9-]+)$\s(?P<content>(^#(| .*)$\s)+?)^# \/\/\/$
/m
str = '# /// pyproject
# [run]
# dependencies = ["requests<3"]
# ///
#
# This data is no longer being read
# if someone has accidentally bridged
# two metadata blocks without a blank
# line.
#
# /// pyproject
# With the mode set to lazy instead
# this can be parsed as a second
# pyproject block and give the expected
# error for there being two blocks
# of the same type.
# ///
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end