import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^# /// (?P<type>[a-zA-Z0-9-]+)$\\s(?P<content>(^#(| .*)$\\s)+?)^# ///$\n";
final String string = "# /// pyproject\n"
+ "# [run]\n"
+ "# dependencies = [\"requests<3\"]\n"
+ "# ///\n"
+ "#\n"
+ "# This data is no longer being read\n"
+ "# if someone has accidentally bridged\n"
+ "# two metadata blocks without a blank\n"
+ "# line.\n"
+ "#\n"
+ "# /// pyproject\n"
+ "# With the mode set to lazy instead \n"
+ "# this can be parsed as a second\n"
+ "# pyproject block and give the expected\n"
+ "# error for there being two blocks\n"
+ "# of the same type.\n"
+ "# ///\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}