using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\b";
string input = @"000000000000000
00
01
99
255
256
100
150
175
200
250";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}