re = /\b(1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\b/
str = '000000000000000
00
01
99
255
256
100
150
175
200
250'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end