// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\b").unwrap();
let string = "000000000000000
00
01
99
255
256
100
150
175
200
250";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}