$re = '/\b(1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\b/';
$str = '000000000000000
00
01
99
255
256
100
150
175
200
250';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);