import Foundation
let pattern = #"\b(1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
000000000000000
00
01
99
255
256
100
150
175
200
250
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)