const regex = /\b(1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\\b', 'g')
const str = `000000000000000
00
01
99
255
256
100
150
175
200
250`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}