package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\b`)
var str = `000000000000000
00
01
99
255
256
100
150
175
200
250`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}