#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[^\d])(\d)(?=[^\d])"
Local $sString = "PT1S" & @CRLF & _
"PT1M" & @CRLF & _
"PT1H" & @CRLF & _
"PT1M1S" & @CRLF & _
"PT1H1S" & @CRLF & _
"PT1H1M1S" & @CRLF & _
"PT10H1M13S" & @CRLF & _
"PT10H1S" & @CRLF & _
"PT1M11S"
Local $sSubst = "0\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)