const regex = /(?<=[^\d])(\d)(?=[^\d])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[^\\d])(\\d)(?=[^\\d])', 'gm')
const str = `PT1S
PT1M
PT1H
PT1M1S
PT1H1S
PT1H1M1S
PT10H1M13S
PT10H1S
PT1M11S`;
const subst = `0\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);