use strict;
my $str = 'PT1S
PT1M
PT1H
PT1M1S
PT1H1S
PT1H1M1S
PT10H1M13S
PT10H1S
PT1M11S';
my $regex = qr/(?<=[^\d])(\d)(?=[^\d])/mp;
my $subst = '0\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";