import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[^\\d])(\\d)(?=[^\\d])";
final String string = "PT1S\n"
+ "PT1M\n"
+ "PT1H\n"
+ "PT1M1S\n"
+ "PT1H1S\n"
+ "PT1H1M1S\n"
+ "PT10H1M13S\n"
+ "PT10H1S\n"
+ "PT1M11S";
final String subst = "0\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}