using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[^\d])(\d)(?=[^\d])";
string substitution = @"0\1";
string input = @"PT1S
PT1M
PT1H
PT1M1S
PT1H1S
PT1H1M1S
PT10H1M13S
PT10H1S
PT1M11S";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}