import Foundation
let pattern = #"(?<=[^\d])(\d)(?=[^\d])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
PT1S
PT1M
PT1H
PT1M1S
PT1H1S
PT1H1M1S
PT10H1M13S
PT10H1S
PT1M11S
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)