$re = '/(?<=[^\d])(\d)(?=[^\d])/m';
$str = 'PT1S
PT1M
PT1H
PT1M1S
PT1H1S
PT1H1M1S
PT10H1M13S
PT10H1S
PT1M11S';
$subst = "0\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;