#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![\w-])(row)[^-\w!@$%^&*)_+\-=\[\]{};':"\\|,.\/?]"
Local $sString = "row" & @CRLF & _
".row" & @CRLF & _
"row-label" & @CRLF & _
"bowrow" & @CRLF & _
"bow.row" & @CRLF & _
" row > other" & @CRLF & _
"rowwer" & @CRLF & _
"bow>row" & @CRLF & _
"bow > row" & @CRLF & _
">row" & @CRLF & _
"row>other" & @CRLF & _
"" & @CRLF & _
"bow-row" & @CRLF & _
"bow-row-bow" & @CRLF & _
"row$" & @CRLF & _
"" & @CRLF & _
"bow.row" & @CRLF & _
"" & @CRLF & _
"row#" & @CRLF & _
"" & @CRLF & _
"row(nth-child)" & @CRLF & _
"" & @CRLF & _
"row > row" & @CRLF & _
"" & @CRLF & _
"ABrow > row" & @CRLF & _
"" & @CRLF & _
"row#something"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")