const regex = /(?<![\w-])(row)[^-\w!@$%^&*)_+\-=\[\]{};':"\\|,.\/?]/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![\\w-])(row)[^-\\w!@$%^&*)_+\\-=\\[\\]{};\':"\\\\|,.\\\/?]', 'mg')
const str = `row
.row
row-label
bowrow
bow.row
row > other
rowwer
bow>row
bow > row
>row
row>other
bow-row
bow-row-bow
row\$
bow.row
row#
row(nth-child)
row > row
ABrow > row
row#something`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}