import re
regex = re.compile(r"(?<![\w-])(row)[^-\w!@$%^&*)_+\-=\[\]{};':\"\\|,.\/?]", flags=re.MULTILINE)
test_str = ("row\n"
".row\n"
"row-label\n"
"bowrow\n"
"bow.row\n"
" row > other\n"
"rowwer\n"
"bow>row\n"
"bow > row\n"
">row\n"
"row>other\n\n"
"bow-row\n"
"bow-row-bow\n"
"row$\n\n"
"bow.row\n\n"
"row#\n\n"
"row(nth-child)\n\n"
"row > row\n\n"
"ABrow > row\n\n"
"row#something")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")