using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\w-])(row)[^-\w!@$%^&*)_+\-=\[\]{};':""\\|,.\/?]";
string input = @"row
.row
row-label
bowrow
bow.row
row > other
rowwer
bow>row
bow > row
>row
row>other
bow-row
bow-row-bow
row$
bow.row
row#
row(nth-child)
row > row
ABrow > row
row#something";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}