$re = '/(?<![\w-])(row)[^-\w!@$%^&*)_+\-=\[\]{};\':"\\\\|,.\/?]/m';
$str = 'row
.row
row-label
bowrow
bow.row
row > other
rowwer
bow>row
bow > row
>row
row>other
bow-row
bow-row-bow
row$
bow.row
row#
row(nth-child)
row > row
ABrow > row
row#something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);