re = /(?<![\w-])(row)[^-\w!@$%^&*)_+\-=\[\]{};':"\\|,.\/?]/m
str = 'row
.row
row-label
bowrow
bow.row
row > other
rowwer
bow>row
bow > row
>row
row>other
bow-row
bow-row-bow
row$
bow.row
row#
row(nth-child)
row > row
ABrow > row
row#something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end