use strict;
my $str = 'row
.row
row-label
bowrow
bow.row
row > other
rowwer
bow>row
bow > row
>row
row>other
bow-row
bow-row-bow
row$
bow.row
row#
row(nth-child)
row > row
ABrow > row
row#something';
my $regex = qr/(?<![\w-])(row)[^-\w!@$%^&*)_+\-=\[\]{};':"\\|,.\/?]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}