package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https:\/\/)?(.*?)(?:\.ingest\.sentry\.io)(.*)$`)
var str = `https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}