// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:https:\/\/)?(.*?)(?:\.ingest\.sentry\.io)(.*)$").unwrap();
let string = "https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}