const regex = /^(?:https:\/\/)?(.*?)(?:\.ingest\.sentry\.io)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https:\\\/\\\/)?(.*?)(?:\\.ingest\\.sentry\\.io)(.*)$', 'gm')
const str = `https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}