import re
regex = re.compile(r"^(?:https:\/\/)?(.*?)(?:\.ingest\.sentry\.io)(.*)$", flags=re.MULTILINE)
test_str = "https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")