re = /^(?:https:\/\/)?(.*?)(?:\.ingest\.sentry\.io)(.*)$/m
str = 'https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end